Java agent 4.0.0

Released on: 
Wednesday, April 4, 2018 - 09:40

Improvements

  • Removed the SSL configuration option: SSL is now always used in communication with New Relic servers. The newrelic.yml ssl configuration and -Dnewrelic.config.ssl system property are no longer used. Setting either value to anything other than true will result in logging a warning.
  • Minimum version required for use in EU datacenter.

Fixes

  • Fixes an issue where the thread profiler could fail to report. In this case, the agent logged a java.lang.StackOverflowError.