Java Agent 3.2.1

Released on: 
Friday, December 6, 2013 - 23:06

Notes

  • Fix: Exceptions thrown from conflicting JAXB versions

    The New Relic Java agent now supports customers using any JAXB or Xerces version. This bug was introduced in version 3.1.0.

  • Fix: Usage of the newrelic.bootstrap_classpath system property

    In version 3.2.0, the newrelic.bootstrap_classpath system property caused an IllegalAccessError. That bug has been fixed. Note also that this system property has been deprecated and should not be used.

  • Fix: Data collection for customers using the IBM JVM without WebSphere

    New Relic now supports customers using an IBM JVM without running WebSphere. In this scenario, you must set the sync_startup flag set to true in the common section of their newrelic.yml.

    sync_startup: true