• /
  • Log in

Kubernetes integration: compatibility and requirements

New Relic's Kubernetes integration can be installed directly on a server or VM, or through several cloud platforms, such as GKE, EKS, AKS, or OpenShift. Each has a different compatibility with our integration.

Compatibility

EOL NOTICE

We're discontinuing support for several capabilities in December 2021, including Kubernetes instrumentation support for versions v1.10 to v1.15. For more details, including how you can easily prepare for this transition, see our Explorers Hub post.

Our Kubernetes integration is compatible with the following versions, depending on the installation mode:

Install mode or feature

Kubernetes versions

Kubernetes cluster

Currently tested with versions 1.16 to 1.22

Kubernetes cluster GKE

Currently tested with versions 1.17 to 1.19

Kubernetes cluster EKS (EC2 nodes or Fargate)

Compatible with version 1.16 or higher

Kubernetes cluster AKS

Compatible with version 1.16 or higher

Kubernetes cluster OpenShift

Currently tested with versions 4.6

Kubernetes cluster VMware Tanzu

Compatible with VMware Tanzu (Pivotal Platform) version 2.5 to 2.11, and Ops Manager version 2.5 to 2.10

Control plane monitoring

Compatible with version 1.16 or higher

Service monitoring

Compatible with version 1.16 or higher

Requirements

The New Relic Kubernetes integration has the following requirements:

Install using Helm

For detailed instructions about how to install our integration using Helm, see Manual install using Helm.

For more help

If you need more help, check out these support and learning resources:

Create issueEdit page
Copyright © 2021 New Relic Inc.