Kubernetes integration: compatibility and requirements

New Relic's Kubernetes integration can be installed directly on a server or VM, or through several cloud platforms, such as GKE, EKS, AKS, or OpenShift. Each has a different compatibility with our integration.

Effective Wednesday, 12 August 2020, Kubernetes integration v1.7 or lower will be deprecated. To avoid losing data, upgrade to the latest version. For more information, read our New Relic Explorers Hub post or contact your New Relic account team.

Compatibility

Our Kubernetes integration is compatible with the following versions, depending on the installation mode:

Install mode or feature Kubernetes versions
Kubernetes cluster

Currently tested with versions 1.10 to 1.17

Kubernetes cluster GKE

Currently tested with versions 1.10 and 1.17

Kubernetes cluster EKS

Currently tested with version 1.11

Kubernetes cluster AKS

Currently tested with version 1.11

Kubernetes cluster OpenShift

Currently tested with versions 3.7, 3.9, 4.2, 4.3 and 4.4

Control plane monitoring Compatible with version 1.11 or higher
Service monitoring Compatible with version 1.13 or higher

Requirements

The New Relic Kubernetes integration has the following requirements:

Install using Helm

For compatibility and requirements when installing the Kubernetes integration using Helm, see Alternative install using Helm.

For more help

If you need more help, check out these support and learning resources: