GCP integration: API authentication errors

Problem

You want to integrate your Google Cloud Platform (GCP) services with New Relic Infrastructure, but you see API authentication errors.

Solution

To resolve the problem:

  1. Go to infrastructure.newrelic.com > Integrations > Google Cloud Platform.
  2. From your GCP account page, select Reauthorize New Relic.
  3. Follow standard procedures to connect your GCP services to New Relic Infrastructure.

Cause

Common reasons for this error include:

  • The authorization for New Relic to use GCP APIs has been revoked manually by the user from the Google account management application.
  • The authorization for New Relic to use GCP APIs does not include one or more of the permissions (Google OAuth scopes) needed to query one or more of the GCP APIs.
  • The authorization for New Relic to use GCP APIs has expired.

For more help

Recommendations for learning more: