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アマゾンからのレートリミットアラート

問題

New Relic ダッシュボード の AWS アカウントで、Amazon EC2 および/または ELB の API 呼び出し数が多いため、AWS の使用量が大幅に増加しています。これは、Amazon からのレート制限アラートとして表示されます。これにより、 CloudWatch の請求額が増加することもあります

解決

スロットリングの問題が発生している場合は、以下の解決策を試してみてください。

  1. インフラストラクチャ エージェントの構成設定を調整することを検討してください
  2. スロットリング問題の原因となっているAWSインテグレーション を切断します。
  3. support.newrelic.com に連絡して、各AWSインテグレーションに代わって行われる通話を無効にしてください。

原因

Amazon 統合は、統合によって異なる ポーリング間隔に従って AWS サービスにクエリを実行します。ポーリング間隔により、AWS データが最新であることが保証され、各間隔ですべての AWS エンティティがポーリングされます。

  • ELB 統合は、Amazon ELB API への呼び出しを実行します。
  • EC2、VPC、および EBS の統合は、Amazon EC2 API への呼び出しを実行します。

大量のAWS統合エンティティがある場合、ポーリング間隔がAmazonとNew Relicの間で通信されるデータをスロットルすることがあります。例えば、200台のElastic Load Balancerがある場合、New Relicは5分ごとにそれらのロードバランサーのデータを引き出すためにAPIコールを行います。

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