Error message

The page you requested does not exist. For your convenience, a search was performed using the query "docs general does rpm work with bundler gem".

Search results for "docs general does rpm work with bundler gem"

  1. Ruby agent installation

    ...For tips to install your New Ruby agent, watch this video (approximately 6 minutes). View more videos and tutorials at learn.newrelic.com. Install the gem The New Relic Ruby agent's gem is available from rubygems.org as newrelic_rpm. For applications using Bundler, add this gem to the Gemfile: gem 'newrelic_rpm'...

  2. Incompatible gems

    ...Problem You are using a Ruby gem that is incompatible with the New Relic Ruby agent. Solution While New Relic strives to be compatible with all gems, there are some that will not work properly with the Ruby agent. This details incompatible gems and known workarounds. db-charmer Problem: The db-charmerĀ gem...

  3. Updating deprecated Ruby agents

    ...name, subscription and billing information, and license key. It also lists the latest Ruby agent version and a link to the update instructions. In general, to update to the latest Ruby agent version: If you use bundler to manage your application's dependencies, then run bundle update newrelic_rpm. If...

  4. Third party instrumentation

    ...to instrument third-party gems with the Ruby agent, as well as some best practices for interacting with the agent. This is useful if you are using a gem that the Ruby agent does not instrument by default, or if you are a gem author who wants to add instrumentation for your library. Contents Finding third-party...

  5. No log file (Ruby)

    ...newrelic_agent.log file, try the following steps to diagnose: Verify that the agent is actually being required by your application: Ensure that the newrelic_rpm gem line in your Gemfile is not marked with require: false, which prevents Bundler from requiring the gem. You can remove the require: false statement...

  6. Ruby agent installation: Rails plugin

    ...These instructions are for installing the Ruby agent as a Rails plugin. For most use cases, you should instead install the agent gem. Contents InstallĀ the New Relic Rails plugin New Relic strongly recommends installing the Ruby agent as a gem in order to have better control over versions and dependencies...

  7. Mongo instrumentation

    ...The Ruby agent has built-in instrumentation for MongoDB queries made via the mongo gem. Contents Supported gems This summarizes New Relic' Ruby agent support for gems by version. Gem version Comments mongo 1.8 and 1.9 Supported by New Relic's Ruby agent 3.7.1 or higher mongo 2.0 Not supported mongo 2...

  8. Rackspace Cloud Load Balancer plugin

    ...Contents Prerequisites Make sure your system has these components installed: Ruby (version 1.8.7 or higher) Rubygems (version 1.3.7 or higher) Ruby bundler gem A New Relic account Rackspace Load Balancer with logging enabled Installing the plugin If you have load balancers in multiple regions, configure...

  9. No data with Unicorn

    ...Ruby agent version 3.8.0 or higher, you should not need to do any additional configuration. If you're using a supported web framework, the agent should work out of the box regardless of your Unicorn configuration. If you are using a Ruby agent version prior to 3.8.0 with Unicorn, you will need to do one...

  10. Page load timing for Java

    ...under browser_monitoring to false in your newrelic.yml. browser_monitoring: auto_instrument: false Restart your application. Flush the app server's work cache. Flushing the work cache is necessary because it forces the app server to recompile JSPs, which is when auto-instrumentation occurs. Disable ...