• 로그인

사용자의 편의를 위해 제공되는 기계 번역입니다.

영문본과 번역본이 일치하지 않는 경우 영문본이 우선합니다. 보다 자세한 내용은 이 페이지를 방문하시기 바랍니다.

문제 신고

몽고 계측

Ruby 에이전트에는 mongo gem을 통해 생성된 MongoDB 쿼리를 위한 내장 도구가 있습니다.

지원되는 보석

이것은 버전별 gem에 대한 Ruby 에이전트의 지원을 요약합니다.

보석 버전

코멘트

mongo 1.8 및 1.9

New Relic의 Ruby 에이전트 3.7.1 이상에서 지원

mongo 2.0

지원되지 않음

mongo 2.1 이상

New Relic의 Ruby 에이전트 3.13.1 이상이 필요합니다.

기타 보석

Mongoid 2/3/4 및 Moped에 대한 지원은 현재 타사 gem을 통해서만 제공됩니다. 관련 프로젝트에 대한 링크는 extends_newrelic_rpm 을 참조하십시오.

타사 및 extends_newrelic_rpm 계측

extends_newrelic_rpmnewrelic_mongo gem은 모두 mongo 에 대한 기본 계측을 제공합니다. New Relic은 Ruby 에이전트의 내장 Mongo 지원과 함께 이러한 gem을 통해 Mongo 계측을 실행하는 것을 권장하지 않습니다. 이는 전체 데이터베이스 시간과 같은 메트릭을 두 배로 계산할 수 있습니다.

또한 extends_newrelic_rpmnewrelic_mongo gem은 둘 다 사용자 환경에서 gem을 완전히 제거할 수 없는 경우 비활성화하는 데 사용할 수 있는 고유한 설정을 사용합니다. 이러한 타사 보석의 경우 newrelic.ymldisable_mongodb: false 를 설정합니다.

계측 비활성화

에이전트에서 Mongo 계측을 비활성화하려면 newrelic.yml 에 다음을 추가하세요.

disable_mongo: true
Copyright © 2022 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.