• 로그인지금 시작하세요

사용자의 편의를 위해 제공되는 기계 번역입니다.

영문본과 번역본이 일치하지 않는 경우 영문본이 우선합니다. 보다 자세한 내용은 이 페이지를 방문하시기 바랍니다.

문제 신고

Java용 WildFly 설치

New Relic의 Java 에이전트를 설치하기 전에 WildFly 버전 이 지원되는지 확인하십시오. 애플리케이션에서 사용하는 WildFly 버전에 따라 추가 구성 단계가 필요할 수 있습니다.

WildFly 11 이전 버전 설치

지원되는 WildFly 버전이 v11 이전인 경우 표준 Java 설치 절차 를 따르십시오. 추가 구성을 수행할 필요 가 없습니다 .

WildFly 버전 11 이상 설치

WildFly 버전 11 이상 을 사용하는 경우 New Relic의 Java 에이전트는 설치 후 추가 구성이 필요합니다.

  1. Java 에이전트를 설치합니다 . 이미 설치한 경우 최신 Java 에이전트 버전으로 업데이트 하십시오. 버전 5.0.0 이상에는 이후 WildFly 버전 11 이상에 대한 수정 사항이 포함되어 있습니다.

  2. 운영 체제에 적합한 standalone 구성 파일을 열고 -javaagent 속성JAVA_OPTS 에 추가합니다. 예를 들어 Linux를 사용하는 경우 Windows의 경우 /bin/standalone.conf 파일 또는 /bin/standalone.conf.bat 을 편집합니다.

  3. standalone 스크립트에서 다음 옵션 중 하나를 사용하여 JBoss 모듈 시스템 패키지에 com.newrelic 을 추가하여 에이전트 jar 가 모든 JBoss 모듈에 표시되는지 확인합니다.

    • 권장 사항: 옵션 1 ( -javaagent 속성 추가와 동일):

      JAVA_OPTS="$JAVA_OPTS -Djboss.modules.system.pkgs=$JBOSS_MODULES_SYSTEM_PKGS,com.newrelic"
    • 옵션 2:

      if [ "x$JBOSS_MODULES_SYSTEM_PKGS" = "x" ]; then
      JBOSS_MODULES_SYSTEM_PKGS="org.jboss.byteman,com.newrelic"
      fi
  4. 애플리케이션 서버를 다시 시작하십시오.

Copyright © 2022 New Relic Inc.

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.