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Événement Fréquent Fluent Bit Restart

Problème

L'agent New Relic Infrastructure envoie des événements Fluent Bit Started et Fluent Bit Stopped excessifs sans redémarrage réel Fluent Bit. Cela peut encombrer les logs, affecter la précision monitoring et augmenter l'ingestion de données, ce qui peut entraîner des frais de facturation inattendus.

Cause

Ceci est dû à un bug dans le composant de résolution du nom d'hôte de l'agent infrastructure. L'agent détecte de manière incorrecte les changements fréquents de nom d'hôte, ce qui déclenche l'envoi par LogForwarderSupervisor de ces faux événements de redémarrage Fluent Bit. Vous pourriez voir des milliers de messages de débogage similaires à l'exemple suivant :

time="2024-04-20T02:46:47Z" level=debug msg="Notifying observers." change=2 component=HostnameResolver
time="2024-04-20T02:46:47Z" level=debug msg="Observer notified." component=HostnameResolver name=LogForwarderSupervisor

Solution

Pour résoudre ce problème, modifiez le comportement de résolution du nom d’hôte dans la configuration de votre agent d’infrastructure. Ce correctif s'applique aux systèmes Windows et Linux.

Ajoutez la configuration suivante à votre fichier de configuration d’agent d’infrastructure :

Linux: /etc/newrelic-infra.yml Windows: C:\Program Files\New Relic\newrelic-infra\newrelic-infra.yml

dns_hostname_resolution: false
override_hostname: "your-server-hostname"

Remplacez "your-server-hostname" par le nom d’hôte réel de votre serveur.

Cette configuration :

  • Désactive les recherches DNS inversées qui peuvent être à l'origine d'une détection instable du nom d'hôte
  • Force l'agent à utiliser un nom d'hôte spécifique, empêchant toute détection de changement de nom d'hôte

Appliquer la configuration

Après avoir ajouté la configuration :

  1. Enregistrez le fichier de configuration.

  2. Redémarrez l'agent New Relic Infrastructure :

    Linux:

    bash
    $
    sudo systemctl restart newrelic-infra

    Windows:

    Restart-Service newrelic-infra

Vérification

Pour confirmer que le problème est résolu :

  1. Monitorez les logs de votre agent infrastructure pour détecter l'absence de messages HostnameResolver répétés.
  2. Vérifiez le dashboard de New Relic pour vous assurer que les événements Fluent Bit Started et Fluent Bit Stopped n'apparaissent plus en continu.
  3. Vérifiez que le transfert de logs continue de fonctionner normalement et que les logs apparaissent comme configurés.

Ressources supplémentaires

Droits d'auteur © 2025 New Relic Inc.

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