Problema
El agente de New Relic Infrastructure está enviando eventos Fluent Bit Started
y Fluent Bit Stopped
excesivos sin reinicios reales Fluent Bit. Esto puede saturar los logs, afectar la precisión del monitoreo y aumentar la ingesta de datos, lo que potencialmente puede generar cargos de facturación inesperados.
Causa
Esto se debe a un error en el componente de resolución de nombre de host del agente de infraestructura. El agente detecta incorrectamente cambios frecuentes en el nombre de host, lo que provoca que LogForwarderSupervisor
envíe estos eventos de resetear Fluent Bit falsos. Es posible que vea miles de mensajes de depuración similares al siguiente ejemplo:
time="2024-04-20T02:46:47Z" level=debug msg="Notifying observers." change=2 component=HostnameResolvertime="2024-04-20T02:46:47Z" level=debug msg="Observer notified." component=HostnameResolver name=LogForwarderSupervisor
Solución
Para resolver este problema, modifique el comportamiento de resolución del nombre de host en la configuración de su agente de infraestructura. Esta solución se aplica tanto a sistemas Windows como Linux.
Agregue la siguiente configuración a su archivo de configuración del agente de infraestructura:
Linux: /etc/newrelic-infra.yml
Windows: C:\Program Files\New Relic\newrelic-infra\newrelic-infra.yml
dns_hostname_resolution: falseoverride_hostname: "your-server-hostname"
Reemplace "your-server-hostname"
con el nombre de host de su servidor actual.
Esta configuración:
- Desactiva las búsquedas DNS inversas que pueden estar causando una detección de nombre de host inestable
- Obliga al agente a emplear un nombre de host específico, lo que evita cualquier detección de cambio de nombre de host
Aplicar la configuración
Luego de agregar la configuración:
Almacene el archivo de configuración.
Resetear el agente de infraestructura New Relic :
Linux:
bash$sudo systemctl restart newrelic-infraWindows:
Restart-Service newrelic-infra
Verificación
Para confirmar que el problema está resuelto:
- Monitorear los logs de su agente de infraestructura para detectar la ausencia de mensajes
HostnameResolver
repetidos. - Verifique el dashboard New Relic para cerciorar de que los eventos
Fluent Bit Started
yFluent Bit Stopped
ya no aparezcan continuamente. - Verifique que el reenvío de logs continúe funcionando normalmente y que los logs aparezcan como configurados.