Using the Bundler gem with New Relic

Starting in version 2.13.0 the Ruby agent will properly handle Bundler initialization under Rails 3 and Rails 2.3.

Add the gem specification to your Gemfile, placing the New Relic gem as low in the list as possible. This allows the frameworks above it to be instrumented when the gem initializes:

gem 'newrelic_rpm'

Note: This approach only works for Bundler versions starting with 1.0.0. For more information on the bundler gem, see the bundler github project.

For more help

If you need additional help, get support at support.newrelic.com.