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Troubleshoot pie chart with uniqueCount over 100%

Problem

Important

As of April 12, 2021, we are upgrading Insights to an improved web and mobile experience! All of your Insights URLs will be redirected automatically to the corresponding dashboards in New Relic One. For more details about this migration and how you can easily plan for this transition, see our Explorers Hub post.

When using a pie chart with the uniqueCount aggregator function, the percentages add up to more than 100%.

Solution

Using a bar chart or table may provide a more accurate visualization of uniqueCount data.

Cause

The attributes being uniquely counted may be present in multiple facets. This overlap may result in the facet percentages adding up to more than 100%.

For example, in the query SELECT uniqueCount(user) FROM PageView FACET appName, a single unique user may use multiple applications. Each of these users will be included in the unique value for each of the appropriate facets (applications), but the total number of unique users will not change.

crop-pie-chart-uniquecount.png

insights.newrelic.com > Query > (query using uniqueCount): Pie charts using uniqueCount can produce percentages that add up to more than 100%. In this example, you have 200 unique users. Of those, 198 of those users (99% of 200 unique users) have accessed your "Account" app, and 196 users (98% of 200 unique users) have accessed your "Store" app.

For more help

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